summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 07:49:27 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 07:49:27 +0000
commit223ed4a98962c088aee84ca6ceb33798e92ac473 (patch)
tree64b2c2d39f9a9c8ffcf4a920751c2f5aa57f8b68 /Makefile.am
parent080080fa23312d15be53ab53dbbd025591afba1f (diff)
Should not need -D_POSIX_PTHREAD_SEMANTICS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 007c5de1..0f7a04ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,9 +41,9 @@ endif
# Set flags for Solaris.
if IS_SUNOS
if IS_GCC
-AM_CPPFLAGS += -D_XPG6 -D_POSIX_PTHREAD_SEMANTICS
+AM_CPPFLAGS += -D_XPG6
else
-AM_CPPFLAGS += -D_XPG4_2 -D_POSIX_PTHREAD_SEMANTICS
+AM_CPPFLAGS += -D_XPG4_2
endif
endif