summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 07:42:45 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 07:42:45 +0000
commit080080fa23312d15be53ab53dbbd025591afba1f (patch)
tree2d5d6e5acb96e7dbeb3eac561d238255eae24681 /Makefile.am
parent3cc24861060b02637a0522176cc185c1c967aec3 (diff)
Use AC_USE_SYSTEM_EXTENSIONS and explicitly check for daemon() in headers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 413bd590..007c5de1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,12 +14,6 @@ dist-hook:
# Preprocessor flags.
AM_CPPFLAGS += @XOPEN_DEFINES@ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf\""
-# glibc as usual does things ass-backwards and hides useful things by default,
-# so everyone has to add this.
-if IS_GLIBC
-AM_CFLAGS += -D_GNU_SOURCE
-endif
-
# Set flags for gcc.
if IS_GCC
AM_CFLAGS += -std=gnu99 -O2
@@ -47,9 +41,9 @@ endif
# Set flags for Solaris.
if IS_SUNOS
if IS_GCC
-AM_CPPFLAGS += -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
+AM_CPPFLAGS += -D_XPG6 -D_POSIX_PTHREAD_SEMANTICS
else
-AM_CPPFLAGS += -D_XPG4_2 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS
+AM_CPPFLAGS += -D_XPG4_2 -D_POSIX_PTHREAD_SEMANTICS
endif
endif