summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPhilipp Korber <philippkorber@gmail.com>2018-05-11 14:56:04 +0200
committerPhilipp Korber <philippkorber@gmail.com>2018-05-11 14:56:04 +0200
commita95f660d7b20b40158f23465f3e8f583480e5f83 (patch)
tree67bf333fb3f422c67bf30111e7fd9ad0ac267d59 /Cargo.toml
parent760a42222cde5ef3a0e26af4174149838ef54d7b (diff)
chore(api+deps): strongly simplified api and uses changed deps
- the api was stringly simplified - uses new-tokio-smtp instead of tokio-smtp - inital commit of the changed api, some parts are not commit yet as they still have to be changed including e.g. the integration tests
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1cfdb3a..e343bdd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,5 +11,9 @@ readme = "./README.md"
repository = "https://github.com/1aim/mail-smtp"
[dependencies]
-mail = { git="https://github.com/1aim/mail" }
+futures = "0.1"
+failure = "0.1.1"
+mail-types = { git="https://github.com/1aim/mail-types" }
+mail-common = { git="https://github.com/1aim/mail-common" }
+mail-headers = { git="https://github.com/1aim/mail-headers" }
new-tokio-smtp = { git="https://github.com/1aim/new-tokio-smtp" }