summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-04-05 11:30:50 +0200
committerMatthias Beyer <mail@beyermatthias.de>2021-04-05 11:30:50 +0200
commit4c4c637f7467bf60eea2d283edaf438ead5fcc31 (patch)
tree5f78106a8d14d36d0d35091bf37bc4c1ad7e9955 /shell.nix
parent8ef5f5a8ad82c2f3b57795b16ce7b4458ad576f0 (diff)
Update shell.nix
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/shell.nix b/shell.nix
index 01160ab..f496c89 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,9 +1,17 @@
-{ pkgs ? (import <nixpkgs> {}) }:
+{ ... }:
let
- env = with pkgs.rustChannels.stable; [
- rust
- cargo
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+
+ env = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
];
dependencies = with pkgs; [
@@ -17,11 +25,12 @@ let
zlib
dbus
libtool
+ protobuf
];
in
pkgs.mkShell rec {
buildInputs = env ++ dependencies;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+ PROTOC = "${pkgs.protobuf}/bin/protoc";
}
-