summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/shell.nix b/shell.nix
index 01160ab..f496c89 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,9 +1,17 @@
-{ pkgs ? (import <nixpkgs> {}) }:
+{ ... }:
let
- env = with pkgs.rustChannels.stable; [
- rust
- cargo
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+
+ env = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
];
dependencies = with pkgs; [
@@ -17,11 +25,12 @@ let
zlib
dbus
libtool
+ protobuf
];
in
pkgs.mkShell rec {
buildInputs = env ++ dependencies;
LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+ PROTOC = "${pkgs.protobuf}/bin/protoc";
}
-