summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRyan Leckey <leckey.ryan@gmail.com>2018-07-02 15:26:09 -0700
committerRyan Leckey <leckey.ryan@gmail.com>2018-07-02 15:26:09 -0700
commit0226b134bb1871fa4918b52a83073db748bc1b4d (patch)
tree49b60220b559b264e2e7d0b7f9041d9b4472310a /Cargo.toml
parent5e5f1a7f000dc227070ccb4bd8e0e3c1c4948282 (diff)
parentaa427d992894f4a098bd77b20d9f10801bc916e7 (diff)
Merge branch 'feature/ini' of https://github.com/woodgear/config-rs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c37b1cf..a87620c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,10 +14,12 @@ license = "MIT/Apache-2.0"
travis-ci = { repository = "mehcode/config-rs" }
[features]
-default = ["toml", "json", "yaml", "hjson"]
+default = ["toml", "json", "yaml", "hjson","ini"]
json = ["serde_json"]
yaml = ["yaml-rust"]
hjson = ["serde-hjson"]
+ini = ["rust-ini"]
+
[dependencies]
lazy_static = "1.0"
@@ -28,6 +30,7 @@ toml = { version = "^0.4.1", optional = true }
serde_json = { version = "^1.0.2", optional = true }
yaml-rust = { version = "^0.4", optional = true }
serde-hjson = { version = "^0.8.1", optional = true }
+rust-ini = { version = "^0.12", optional = true }
[dev-dependencies]
serde_derive = "^1.0.8"