summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-12-07 22:29:11 +0100
committerBram Moolenaar <Bram@vim.org>2017-12-07 22:29:11 +0100
commite4b78e2a42e9030348770764c478b73caa925539 (patch)
treeb27e254f7dcaf5a4e38a1515ff0e2a5c5bce80ea /src/configure.ac
parent3388d334572f9d65a603d09d75e363805d96c5d9 (diff)
patch 8.0.1379: configure check for selinux does not check for header filev8.0.1379
Problem: Configure check for selinux does not check for header file. Solution: Add an AC_CHECK_HEADER(). (Benny Siegert)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 938a77f914..d08986ed98 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -433,8 +433,9 @@ if test "x$found_smack" = "x"; then
if test "$enable_selinux" = "yes"; then
AC_MSG_RESULT(no)
AC_CHECK_LIB(selinux, is_selinux_enabled,
+ [AC_CHECK_HEADER(selinux/selinux.h,
[LIBS="$LIBS -lselinux"
- AC_DEFINE(HAVE_SELINUX)])
+ AC_DEFINE(HAVE_SELINUX)])])
else
AC_MSG_RESULT(yes)
fi