summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-10 18:13:05 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-10 18:13:05 +0200
commitd088240b96bc8b2bdba9242dcb9e3d36f1e16c48 (patch)
tree65228ebe634314e7d03e3449276b913bf46873e9 /src/configure.ac
parentf59c6e8cee092433d325ba21a107654a8d84f776 (diff)
patch 8.0.1686: Python does not work when configuring with specific dirv8.0.1686
Problem: Python does not work when configuring with specific dir. (Rajdeep) Solution: Do define PYTHON_HOME and PYTHON3_HOME in configure if the Python config dir was specified.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index fd667f8e33..e2867b422e 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1157,7 +1157,7 @@ if test "$enable_pythoninterp" = "yes" -o "$enable_pythoninterp" = "dynamic"; th
AC_ARG_WITH(python-config-dir,
[ --with-python-config-dir=PATH Python's config directory],
- [ vi_cv_path_python_conf="${withval}" ] )
+ [ vi_cv_path_python_conf="${withval}"; have_python_config_dir=1 ] )
AC_CACHE_CHECK(Python's configuration directory,vi_cv_path_python_conf,
[
@@ -1255,6 +1255,11 @@ eof
else
PYTHON_CFLAGS="-I${vi_cv_path_python_pfx}/include/python${vi_cv_var_python_version} -I${vi_cv_path_python_epfx}/include/python${vi_cv_var_python_version}"
fi
+ if test "X$have_python_config_dir" = "X1"; then
+ dnl Define PYTHON_HOME if --with-python-config-dir was used
+ PYTHON_CFLAGS="${PYTHON_CFLAGS} -DPYTHON_HOME='\"${vi_cv_path_python_pfx}\"'"
+
+ fi
PYTHON_SRC="if_python.c"
PYTHON_OBJ="objects/if_python.o"
if test "${vi_cv_var_python_version}" = "1.4"; then
@@ -1399,7 +1404,7 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
AC_ARG_WITH(python3-config-dir,
[ --with-python3-config-dir=PATH Python's config directory],
- [ vi_cv_path_python3_conf="${withval}" ] )
+ [ vi_cv_path_python3_conf="${withval}"; have_python3_config_dir=1 ] )
AC_CACHE_CHECK(Python's configuration directory,vi_cv_path_python3_conf,
[
@@ -1464,6 +1469,10 @@ eof
else
PYTHON3_CFLAGS="-I${vi_cv_path_python3_pfx}/include/python${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags} -I${vi_cv_path_python3_epfx}/include/python${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags}"
fi
+ if test "X$have_python3_config_dir" = "X1"; then
+ dnl Define PYTHON3_HOME if --with-python-config-dir was used
+ PYTHON3_CFLAGS="${PYTHON3_CFLAGS} -DPYTHON3_HOME='L\"${vi_cv_path_python3_pfx}\"'"
+ fi
PYTHON3_SRC="if_python3.c"
PYTHON3_OBJ="objects/if_python3.o"