summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-08-04 15:13:34 +0200
committerBram Moolenaar <Bram@vim.org>2018-08-04 15:13:34 +0200
commit87ea64ca965ca00b3e72776c39355964293f2ace (patch)
treef7db063faf76b4fc348b569107b60057ff758a4a /src/configure.ac
parent82593c1a3a2c5e39603ed76819f83b1197c06c8b (diff)
patch 8.1.0237: Ruby on Cygwin doesn't always workv8.1.0237
Problem: Ruby on Cygwin doesn't always work. Solution: Use LIBRUBY_SO if LIBRUBY_ALIASES isn't set. (Ken Takata)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 0d8ea32d34..8994f3c90a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1956,6 +1956,9 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
AC_DEFINE(FEAT_RUBY)
if test "$enable_rubyinterp" = "dynamic"; then
libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_ALIASES']].split[[0]]"`
+ if test -z "$libruby_soname"; then
+ libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_SO']]"`
+ fi
AC_DEFINE(DYNAMIC_RUBY)
RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby_soname\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
RUBY_LIBS=