summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-02-05 20:44:24 +0100
committerBram Moolenaar <Bram@vim.org>2020-02-05 20:44:24 +0100
commit7077892a7918845a00ce8d7833b43cc6cbed2081 (patch)
tree414211672011c7eb31368a65a384fd1cb58bfc17 /src/configure.ac
parent07ada5ff2fd8f22ed3233ae5c4ddf87c7b3f56fe (diff)
patch 8.2.0213: configure does not recognize gcc 10.0 and laterv8.2.0213
Problem: Configure does not recognize gcc 10.0 and later. Solution: Adjust the pattern matching the version number. (Sergei Trofimovich, closes #5580)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index a098da82ec..bf10eac551 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2195,7 +2195,7 @@ else
fi
dnl On my HPUX system the X include dir is found, but the lib dir not.
- dnl This is a desparate try to fix this.
+ dnl This is a desperate try to fix this.
if test -d "$x_includes" && test ! -d "$x_libraries"; then
x_libraries=`echo "$x_includes" | sed s/include/lib/`
@@ -4447,7 +4447,7 @@ dnl the number before the version number.
DEPEND_CFLAGS_FILTER=
if test "$GCC" = yes; then
AC_MSG_CHECKING(for GCC 3 or later)
- gccmajor=`echo "$gccversion" | sed -e 's/^\([[1-9]]\)\..*$/\1/g'`
+ gccmajor=`echo "$gccversion" | sed -e 's/^\([[0-9]]\+\)\..*$/\1/g'`
if test "$gccmajor" -gt "2"; then
DEPEND_CFLAGS_FILTER="| sed 's+-I */+-isystem /+g'"
AC_MSG_RESULT(yes)