summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2019-04-11 15:25:40 +0200
committerBram Moolenaar <Bram@vim.org>2019-04-11 15:25:40 +0200
commit26096cc96fc402db45948b3b662a380281585649 (patch)
tree83c6e9aab5786a7c17674d68b121d227fdafaee3 /src/configure.ac
parent730f48fe3691dc62331f3df23cb947bfc33a5add (diff)
patch 8.1.1149: building desktop files fails with older msgfmtv8.1.1149
Problem: Building desktop files fails with older msgfmt. Solution: Add autoconf check. Avoid always building the desktop files.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 2d409b3ca0..be869d1d52 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4298,6 +4298,15 @@ if test "$enable_nls" = "yes"; then
[++_nl_msg_cat_cntr;],
AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_NL_MSG_CAT_CNTR),
AC_MSG_RESULT([no]))
+ AC_MSG_CHECKING([if msgfmt supports --desktop])
+ MSGFMT_DESKTOP=
+ if "$MSGFMT" --help | grep -e '--desktop' >/dev/null; then
+ AC_MSG_RESULT([yes])
+ MSGFMT_DESKTOP="gvim.desktop vim.desktop"
+ else
+ AC_MSG_RESULT([no])
+ fi
+ AC_SUBST(MSGFMT_DESKTOP)
fi
else
AC_MSG_RESULT([no "po/Makefile" - disabled]);