summaryrefslogtreecommitdiffstats
path: root/benches/Cargo.toml
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2020-09-22 15:40:44 -0700
committerGitHub <noreply@github.com>2020-09-22 15:40:44 -0700
commit7ae5b7bd4f93612f91ab504ffb63aa8241c1d7bb (patch)
tree990e22703eb7103b030f5e8bf117557684a9f205 /benches/Cargo.toml
parente09b90ea32385337170ce17eb55ab372f9388af5 (diff)
signal: move driver to runtime thread (#2835)
Refactors the signal infrastructure to move the driver to the runtime thread. This follows the model put forth by the I/O driver and time driver.
Diffstat (limited to 'benches/Cargo.toml')
-rw-r--r--benches/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/benches/Cargo.toml b/benches/Cargo.toml
index 3a90943f..cca0ece5 100644
--- a/benches/Cargo.toml
+++ b/benches/Cargo.toml
@@ -8,6 +8,9 @@ edition = "2018"
tokio = { version = "0.3.0", path = "../tokio", features = ["full"] }
bencher = "0.1.5"
+[target.'cfg(unix)'.dependencies]
+libc = "0.2.42"
+
[[bench]]
name = "spawn"
path = "spawn.rs"
@@ -33,3 +36,8 @@ harness = false
name = "sync_semaphore"
path = "sync_semaphore.rs"
harness = false
+
+[[bench]]
+name = "signal"
+path = "signal.rs"
+harness = false