summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2011-10-06 12:14:22 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2011-10-06 12:14:22 +0000
commita7341715c10377ef7eb41517f237e55df83da167 (patch)
treeb949df42f385e7934fe3e38be213fd7dc32d8baf /configure.ac
parent521bf41d120021fa14cd6c04f148b3ee8e275baa (diff)
Fix some warnings with newer autoconf, from Matt Curtis.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index efa34e14..53cc99aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -336,7 +336,7 @@ AC_CHECK_FUNCS(
# Check for BSD-style integer types.
AC_MSG_CHECKING(for BSD-style unsigned types)
-AC_COMPILE_IFELSE(
+AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[
#include <sys/types.h>
#ifdef HAVE_STDINT_H
@@ -346,7 +346,7 @@ AC_COMPILE_IFELSE(
#endif
int main(void)
{ u_int8_t u8; u_int16_t u16; u_int32_t u32; u_int64_t u64; }
- ],
+ ])],
[AC_DEFINE(HAVE_BSD_TYPES) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no)
)
@@ -370,7 +370,7 @@ fi
# Look for __progname.
AC_MSG_CHECKING(for __progname)
-AC_LINK_IFELSE(
+AC_LINK_IFELSE([AC_LANG_SOURCE(
[
#include <stdio.h>
#include <stdlib.h>
@@ -380,7 +380,7 @@ AC_LINK_IFELSE(
printf("%s\n", cp);
exit(0);
}
- ],
+ ])],
[AC_DEFINE(HAVE___PROGNAME) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no)
)