summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2022-02-16 12:26:23 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2022-04-06 14:19:49 +0100
commit7f40c5b647241e0ac3c71c3c95a8cc33790e707e (patch)
tree8ea17548f1d72b642e46fcc0ee6a0a2db6330eba /configure.ac
parenteabbc80b75ef8e02653c2728d7f646fc6a8f558f (diff)
No not allow static linking on macOS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c71a54b0..fb0ee239 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,11 @@ AC_ARG_ENABLE(
AS_HELP_STRING(--enable-static, create a static build)
)
if test "x$enable_static" = xyes; then
+ case "$host_os" in
+ *darwin*)
+ AC_MSG_ERROR([static linking is not supported on macOS])
+ ;;
+ esac
test "x$PKG_CONFIG" != x && PKG_CONFIG="$PKG_CONFIG --static"
AM_LDFLAGS="-static $AM_LDFLAGS"
LDFLAGS="$AM_LDFLAGS $SAVED_LDFLAGS"