summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2020-04-23 17:27:39 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2020-04-23 17:27:39 +0100
commitf87be8d0521436c47151233f781794dee94fc1df (patch)
tree129675976cc02b17dd837a58ed543fcdc96e5160 /Makefile.am
parent351c5423f0ec8d0267fc2d973990bd55a1a5797b (diff)
Add XDG_CONFIG home to the configuration search paths.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 72b21f0a..a395ecdb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,8 +12,8 @@ dist_EXTRA_tmux_SOURCES = compat/*.[ch]
# Preprocessor flags.
AM_CPPFLAGS += @XOPEN_DEFINES@ \
- -DTMUX_VERSION="\"@VERSION@\"" \
- -DTMUX_CONF="\"$(sysconfdir)/tmux.conf:~/.tmux.conf:~/.config/tmux/tmux.conf\""
+ -DTMUX_VERSION='"@VERSION@"' \
+ -DTMUX_CONF='"$(sysconfdir)/tmux.conf:~/.tmux.conf:$$XDG_CONFIG_HOME/tmux/tmux.conf:~/.config/tmux/tmux.conf"'
# Additional object files.
LDADD = $(LIBOBJS)