summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2014-06-18 08:21:08 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2014-06-18 08:21:08 +0100
commitf5973b77763e3f8da8e8f6483464f6f4bc2f3981 (patch)
treebab2a072b55d3bfead04a264185616e0e1318284 /Makefile.am
parentea5a223a2e8901fa9afa991d147751d8a6789443 (diff)
Build DEBUG with -O2 as well.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5502de86..5f9e0116 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,17 +25,15 @@ endif
# Set flags for gcc. gcc4 whines abouts silly stuff so it needs slightly
# different flags.
if IS_GCC
-CFLAGS += -std=gnu99
+CFLAGS += -std=gnu99 -O2
if IS_DEBUG
-CFLAGS += -O0 -g
+CFLAGS += -g
CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
CFLAGS += -Wdeclaration-after-statement
CPPFLAGS += -DDEBUG
-else
-CFLAGS += -O2
endif
if IS_GCC4
CPPFLAGS += -iquote. -I/usr/local/include
@@ -247,7 +245,7 @@ install-exec-hook:
>$(srcdir)/tmux.1.mdoc; \
else \
sed -e "s|@SYSCONFDIR@|$(sysconfdir)|g" $(srcdir)/tmux.1| \
- $(AWK) -f $(srcdir)/mdoc2man.awk >$(srcdir)/tmux.1.man; \
+ $(AWK) -f$(srcdir)/mdoc2man.awk >$(srcdir)/tmux.1.man; \
fi
$(MKDIR_P) $(DESTDIR)$(mandir)/man1
$(INSTALL_DATA) $(srcdir)/tmux.1.@MANFORMAT@ \