summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2020-04-29 15:21:15 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2020-04-29 15:21:15 +0100
commitd9fa122fd23f9769758026fa9866dda0379f3086 (patch)
tree4e59cd20d7081eaead30c17e4c674016d3791288 /Makefile.am
parentfe601e54171a431ce908f01c1f8aea3166af3d38 (diff)
Do not want -O0 by default.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 97174c1d..a395ecdb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ LDADD = $(LIBOBJS)
if IS_GCC
AM_CFLAGS += -std=gnu99 -O2
if IS_DEBUG
-AM_CFLAGS += -g -O0
+AM_CFLAGS += -g
AM_CFLAGS += -Wno-long-long -Wall -W -Wformat=2
AM_CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
AM_CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare