summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2021-07-14 11:03:19 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2021-07-14 11:03:19 +0100
commitd723466df2adaec4bb655094a942a427633aacff (patch)
tree01ab9819a3d1104160229dd688eec4c8bd4b4c9c /Makefile.am
parentbb4bc8caf4a7fa1680333a42679ca72390b60001 (diff)
Pick default-terminal from the first of tmux-256color, tmux, screen-256color,
screen that is available on the build system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9bb5b89e..dadf13a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,8 @@ dist_EXTRA_tmux_SOURCES = compat/*.[ch]
# Preprocessor flags.
AM_CPPFLAGS += @XOPEN_DEFINES@ \
-DTMUX_VERSION='"@VERSION@"' \
- -DTMUX_CONF='"$(sysconfdir)/tmux.conf:~/.tmux.conf:$$XDG_CONFIG_HOME/tmux/tmux.conf:~/.config/tmux/tmux.conf"'
+ -DTMUX_CONF='"$(sysconfdir)/tmux.conf:~/.tmux.conf:$$XDG_CONFIG_HOME/tmux/tmux.conf:~/.config/tmux/tmux.conf"' \
+ -DTMUX_TERM='"@DEFAULT_TERM@"'
# Additional object files.
LDADD = $(LIBOBJS)