summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 19:22:32 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-22 19:22:32 +0000
commitc57039bc3d829c16fddb7bc49f2e56f65076b772 (patch)
treea263569dd52f96fbe89f97410237d922e0c9fd5b /Makefile.am
parent9c0520f2c52548d0949db172662015a75926ff89 (diff)
Can shorten these by using LIBOBJ.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am79
1 files changed, 8 insertions, 71 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bdc3093..ff9b77b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,9 @@ dist-hook:
# Preprocessor flags.
AM_CPPFLAGS += @XOPEN_DEFINES@ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf\""
+# Additional object files.
+LDADD = $(LIBOBJS)
+
# Set flags for gcc.
if IS_GCC
AM_CFLAGS += -std=gnu99 -O2
@@ -186,82 +189,16 @@ dist_tmux_SOURCES = \
xterm-keys.c
nodist_tmux_SOURCES = osdep-@PLATFORM@.c
+# Add compat file for forkpty.
+if NEED_FORKPTY
+nodist_tmux_SOURCES += compat/forkpty-@PLATFORM@.c
+endif
+
# Add compat file for utf8proc.
if HAVE_UTF8PROC
nodist_tmux_SOURCES += compat/utf8proc.c
endif
-# Add compat for missing or broken functions.
-if NO_FORKPTY
-nodist_tmux_SOURCES += compat/forkpty-@PLATFORM@.c
-endif
-if NO_IMSG
-nodist_tmux_SOURCES += compat/imsg.c compat/imsg-buffer.c
-endif
-if NO_ERR_H
-nodist_tmux_SOURCES += compat/err.c
-endif
-if NO_CLOSEFROM
-nodist_tmux_SOURCES += compat/closefrom.c
-endif
-if NO_DAEMON
-nodist_tmux_SOURCES += compat/daemon.c
-endif
-if NO_GETPROGNAME
-nodist_tmux_SOURCES += compat/getprogname.c
-endif
-if NO_SETPROCTITLE
-nodist_tmux_SOURCES += compat/setproctitle.c
-endif
-if NO_SETENV
-nodist_tmux_SOURCES += compat/setenv.c
-endif
-if NO_STRLCAT
-nodist_tmux_SOURCES += compat/strlcat.c
-endif
-if NO_STRLCPY
-nodist_tmux_SOURCES += compat/strlcpy.c
-endif
-if NO_STRNLEN
-nodist_tmux_SOURCES += compat/strnlen.c
-endif
-if NO_STRNDUP
-nodist_tmux_SOURCES += compat/strndup.c
-endif
-if NO_ASPRINTF
-nodist_tmux_SOURCES += compat/asprintf.c
-endif
-if NO_FGETLN
-nodist_tmux_SOURCES += compat/fgetln.c
-endif
-if NO_FPARSELN
-nodist_tmux_SOURCES += compat/fparseln.c
-endif
-if NO_GETOPT
-nodist_tmux_SOURCES += compat/getopt.c
-endif
-if NO_STRCASESTR
-nodist_tmux_SOURCES += compat/strcasestr.c
-endif
-if NO_STRSEP
-nodist_tmux_SOURCES += compat/strsep.c
-endif
-if NO_VIS
-nodist_tmux_SOURCES += compat/vis.c compat/unvis.c
-endif
-if NO_STRTONUM
-nodist_tmux_SOURCES += compat/strtonum.c
-endif
-if NO_B64_NTOP
-nodist_tmux_SOURCES += compat/base64.c
-endif
-if NO_CFMAKERAW
-nodist_tmux_SOURCES += compat/cfmakeraw.c
-endif
-if NO_REALLOCARRAY
-nodist_tmux_SOURCES += compat/reallocarray.c
-endif
-
# Install tmux.1 in the right format.
install-exec-hook:
if test x@MANFORMAT@ = xmdoc; then \