summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Adam <thomas@xteddy.org>2015-02-15 20:07:48 +0000
committerThomas Adam <thomas@xteddy.org>2015-02-15 20:07:48 +0000
commitc2bbaab2ac06420fa56c872294a9f8d7b326571e (patch)
treee4390c5c357b2a0496e8ef09ffa68bb8f830554e /Makefile.am
parentffb83d23e17e99589f46edc3e08f78dd32936e4e (diff)
Add -Wno-format-nonliteral to Makefile.am
Shut GCC up about non-literal arguments to functions which make use of placeholder expansions (printf, strftime, etc.)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 63e20b17..ccb3c2ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
-CFLAGS += -Wdeclaration-after-statement
+CFLAGS += -Wdeclaration-after-statement -Wno-format-nonliteral
CPPFLAGS += -DDEBUG
endif
if IS_GCC4