summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2017-03-09 15:43:08 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2017-03-09 15:43:08 +0000
commitb79df1dc29c5ca3181be3e6e642f6c51e951e34e (patch)
tree8740f7765aeccd4559cc62f34f76094dc8853da1 /Makefile.am
parent180ebf02081087eec625a25c785985f5d6b5eff4 (diff)
Compat code for strndup and strnlen.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8bfafd40..413bd590 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -228,6 +228,12 @@ endif
if NO_STRLCPY
nodist_tmux_SOURCES += compat/strlcpy.c
endif
+if NO_STRNLEN
+nodist_tmux_SOURCES += compat/strnlen.c
+endif
+if NO_STRNDUP
+nodist_tmux_SOURCES += compat/strndup.c
+endif
if NO_ASPRINTF
nodist_tmux_SOURCES += compat/asprintf.c
endif