summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-10-12 10:52:04 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-10-12 10:52:04 +0100
commit76a9e6f27bb0c7b547989c3b80cf8cc0a148064d (patch)
treed662acef4b0c076c79dabd0d81d074333ecaa91b /Makefile.am
parent12efb40dc5d5f572490eb855e625d5adf0de06ac (diff)
NetBSD needs _OPENBSD_SOURCE for reallocarray.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 81dc4c71..1685c3dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,6 +63,11 @@ if IS_AIX
DEFS += -D_LINUX_SOURCE_COMPAT=1
endif
+# Set flags for NetBSD.
+if IS_NETBSD
+CPPFLAGS += -D_OPENBSD_SOURCE
+endif
+
# List of sources.
dist_tmux_SOURCES = \
alerts.c \