summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2015-06-04 08:50:20 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2015-06-04 08:50:20 +0100
commit75061cb45d68ad3a7a75839a2f658813e697c55e (patch)
tree919e4e666fcab3766dbec6f9dc65beaf3b4e26e6 /Makefile.am
parent20598dff258da1e96a060adba95e8e05bfdd8b3b (diff)
I no longer need to care about GCC 3.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 29294d87..0aec7ae4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,8 +22,7 @@ if IS_GLIBC
CFLAGS += -D_GNU_SOURCE
endif
-# Set flags for gcc. gcc4 whines abouts silly stuff so it needs slightly
-# different flags.
+# Set flags for gcc.
if IS_GCC
CFLAGS += -std=gnu99 -O2
if IS_DEBUG
@@ -32,17 +31,10 @@ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
-CFLAGS += -Wdeclaration-after-statement
+CFLAGS += -Wdeclaration-after-statement -Wno-pointer-sign
CPPFLAGS += -DDEBUG
endif
-if IS_GCC4
CPPFLAGS += -iquote.
-if IS_DEBUG
-CFLAGS += -Wno-pointer-sign
-endif
-else
-CPPFLAGS += -I. -I-
-endif
endif
# Set flags for Solaris.