summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2016-09-01 20:40:03 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2016-09-01 20:40:03 +0100
commit6c94774b70f72952c4c512e4aa59a207ca1c34f2 (patch)
tree04502f9607958f3b4559e3bac5e5668e8d517ab0 /Makefile.am
parentae297cb487590d0bb8e42e21e28926a1f957ad0b (diff)
Add support for using utf8proc with --enable-utf8proc, useful for platforms
(like OS X) where the system implementation is crap. From Joshua Rubin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b411afd..81dc4c71 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -185,7 +185,12 @@ dist_tmux_SOURCES = \
xterm-keys.c
nodist_tmux_SOURCES = osdep-@PLATFORM@.c
-# Pile in all the compat/ stuff that is needed.
+# Add compat file for utf8proc.
+if HAVE_UTF8PROC
+nodist_tmux_SOURCES += compat/utf8proc.c
+endif
+
+# Add compat for missing or broken functions.
if NO_FORKPTY
nodist_tmux_SOURCES += compat/forkpty-@PLATFORM@.c
endif