summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2020-01-28 11:28:30 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2020-01-28 11:28:30 +0000
commit685eb381dec7fc741a15ce11a84d8c96ed66ce42 (patch)
treea68927ec66c1a76d1aea9bef257d51b4a4869d31 /Makefile.am
parentee3d3db364b6c2469c1acaa88bb64341090d3af1 (diff)
Fix for version changes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6902477e..082a467c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,8 +11,9 @@ EXTRA_DIST = \
dist_EXTRA_tmux_SOURCES = compat/*.[ch]
# Preprocessor flags.
-AM_CPPFLAGS += @XOPEN_DEFINES@
-AM_CPPFLAGS += -DTMUX_CONF="\"$(sysconfdir)/tmux.conf:~/.tmux.conf:~/.config/tmux/tmux.conf\""
+AM_CPPFLAGS += @XOPEN_DEFINES@ \
+ -DTMUX_VERSION="\"@VERSION@\"" \
+ -DTMUX_CONF="\"$(sysconfdir)/tmux.conf:~/.tmux.conf:~/.config/tmux/tmux.conf\""
# Additional object files.
LDADD = $(LIBOBJS)