summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2020-11-09 16:41:55 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2020-11-09 16:44:39 +0000
commit3eb1519bd784076f63fed6678b88f918317a2124 (patch)
treeb0ecce81cfe4e4612b2f8979933a7ea18a876846 /Makefile.am
parent0dcb6e5eb4bad32ef5676c533ece81e988a1c03b (diff)
Scaffold for oss-fuzz, from Sergey Nizovtsev.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b84b1e9..b40e0944 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -202,6 +202,12 @@ if HAVE_UTF8PROC
nodist_tmux_SOURCES += compat/utf8proc.c
endif
+if NEED_FUZZING
+check_PROGRAMS = fuzz/input-fuzzer
+fuzz_input_fuzzer_LDFLAGS = $(FUZZING_LIBS)
+fuzz_input_fuzzer_LDADD = $(LDADD) $(tmux_OBJECTS)
+endif
+
# Install tmux.1 in the right format.
install-exec-hook:
if test x@MANFORMAT@ = xmdoc; then \