summaryrefslogtreecommitdiffstats
path: root/crates/starship-cache/Cargo.toml
diff options
context:
space:
mode:
authorMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
committerMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
commit8bb76e08eeacdbeb7b51a2aee1c7cc9dbfba2b81 (patch)
treeda1a891376d494c6a5b0f17caf3f50560c07f228 /crates/starship-cache/Cargo.toml
parenta123df24dcd4b360c71b92a661b8c405dcbcbd62 (diff)
Add binary cachingbinary-caching
Diffstat (limited to 'crates/starship-cache/Cargo.toml')
-rw-r--r--crates/starship-cache/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/crates/starship-cache/Cargo.toml b/crates/starship-cache/Cargo.toml
new file mode 100644
index 000000000..bb66cd150
--- /dev/null
+++ b/crates/starship-cache/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "starship-cache"
+version = "0.1.0"
+authors = ["Starship Contributors"]
+description = "Intelligent caching for Starship"
+edition = "2018"
+license = "ISC"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+dirs = "3.0.2"
+serde = { version = "1.0.126", features = ["derive"] }
+thiserror = "1.0.25"
+toml = "0.5.8"
+
+[dev-dependencies]
+tempfile = "3.2.0"