summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8e9f135..de48dec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,14 +25,17 @@ AC_SEARCH_LIBS([tgetent], [tinfo curses ncursesw ncurses], [HAVE_CURSES=True])
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([langinfo.h locale.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h wchar.h])
+AC_CHECK_HEADERS([fcntl.h limits.h langinfo.h locale.h stdint.h stdlib.h \
+ string.h sys/ioctl.h sys/time.h termios.h unistd.h wchar.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_SIZE_T
# Checks for library functions.
AC_FUNC_MALLOC
-AC_CHECK_FUNCS([mblen memset nl_langinfo pathconf regcomp setlocale strchr strdup strrchr])
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([mblen memset nl_langinfo pathconf regcomp \
+ setlocale strchr strrchr strspn])
AC_CANONICAL_HOST
# OS-specific tests