summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorpgen <p.gen.progs@gmail.com>2017-07-29 16:30:06 +0200
committerpgen <p.gen.progs@gmail.com>2017-12-10 01:21:59 +0100
commitb3564338dd2a7598cb35968d5c806a9e4b744c96 (patch)
tree87619babb44664e43d88fb499c588ad1a18bf979 /configure.ac
parenta67194b3af29ef00586ebb76d275a4bb46150aba (diff)
A giant commit because a lot of things have been rewritten/enhanced/fixedv0.9.10
- Bump to version 0.9.10 * The words acquisition is rewritten and splitted in multiple phases * Add the capacity to (de)select rows an columns containing regexes * -i, -e, -C and -R can be used more than once and have a cumulative effect * Bugfix: -s is able to jump to non selectable words * Bugfix: The attributes are not overloaded when reading configuration files * Bugfix: the right bar is too far right in some cases. * Bugfix: the right shift indicator is omitted in some cases * Add a -x|-X option to set a timeout in seconds * Add a -f option to select an alternative configuration file * Add a -a option to set the attributes of the displayed elements * Add more controls in the selection parser * smenu can now read words directly from a file given as parameter * Rewrite the replace function used by -S/-I/-E with a more sed-like one * Searches should always consider the visual aspect of words (-S/-I/-E)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8e9f135..de48dec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,14 +25,17 @@ AC_SEARCH_LIBS([tgetent], [tinfo curses ncursesw ncurses], [HAVE_CURSES=True])
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([langinfo.h locale.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h wchar.h])
+AC_CHECK_HEADERS([fcntl.h limits.h langinfo.h locale.h stdint.h stdlib.h \
+ string.h sys/ioctl.h sys/time.h termios.h unistd.h wchar.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_SIZE_T
# Checks for library functions.
AC_FUNC_MALLOC
-AC_CHECK_FUNCS([mblen memset nl_langinfo pathconf regcomp setlocale strchr strdup strrchr])
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([mblen memset nl_langinfo pathconf regcomp \
+ setlocale strchr strrchr strspn])
AC_CANONICAL_HOST
# OS-specific tests