summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index 7482376..393322f 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -2,6 +2,7 @@
name = "ipfs-api"
description = "Implementation of an IPFS HTTP API client"
authors = ["Ferris Tseng <ferristseng@fastmail.fm>"]
+edition = "2018"
documentation = "https://docs.rs/ipfs-api"
repository = "https://github.com/ferristseng/rust-ipfs-api"
keywords = ["ipfs"]
@@ -29,8 +30,7 @@ http = "0.1"
hyper = { version = "0.12", optional = true }
hyper-tls = { version = "0.3.2", optional = true }
hyper-multipart-rfc7578 = { version = "0.3", optional = true }
-serde = "1.0"
-serde_derive = "1.0"
+serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.5"
tokio = "0.1"