summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
authorBogdan Arabadzhi <bogdan.today@gmail.com>2019-10-15 12:56:40 +0200
committerBogdan Arabadzhi <bogdan.today@gmail.com>2019-10-15 12:56:40 +0200
commit1f9f0261b425cd2e94a7efd3ae4bdfdab5480e7d (patch)
tree272f4eba88e57e5810c2c17f01a2c559b42c27b9 /ipfs-api/Cargo.toml
parentc0d0f75dc46331a429bf211fc682a42b57a594e3 (diff)
Migrate to Rust 2018 edition
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index 7482376..393322f 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -2,6 +2,7 @@
name = "ipfs-api"
description = "Implementation of an IPFS HTTP API client"
authors = ["Ferris Tseng <ferristseng@fastmail.fm>"]
+edition = "2018"
documentation = "https://docs.rs/ipfs-api"
repository = "https://github.com/ferristseng/rust-ipfs-api"
keywords = ["ipfs"]
@@ -29,8 +30,7 @@ http = "0.1"
hyper = { version = "0.12", optional = true }
hyper-tls = { version = "0.3.2", optional = true }
hyper-multipart-rfc7578 = { version = "0.3", optional = true }
-serde = "1.0"
-serde_derive = "1.0"
+serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_urlencoded = "0.5"
tokio = "0.1"