summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
authorJulius Michaelis <gitter@liftm.de>2021-01-19 00:30:38 +0900
committerJulius Michaelis <gitter@liftm.de>2021-01-19 00:31:44 +0900
commitd53e6d335c3cfde51f6ceebd2da5306f5ed86ce8 (patch)
treec1a094f6fb6a0204ab22b286087832d4ffabada6 /ipfs-api/Cargo.toml
parentc465720a494312aea93aa87e16ff6baf25ef2e11 (diff)
Reorganize features
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml12
1 files changed, 9 insertions, 3 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index 2fba349..1520c95 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -15,9 +15,15 @@ license = "MIT OR Apache-2.0"
travis-ci = { repository = "ferristseng/rust-ipfs-api" }
[features]
-default = ["hyper", "hyper-multipart-rfc7578", "hyper-tls", "failure"]
-actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
-builder = ["typed-builder"]
+default = ["with-hyper-tls", "with-builder"]
+with-hyper-tls = ["with-hyper", "hyper-tls"]
+with-hyper-rustls = ["with-hyper", "hyper-rustls"]
+with-hyper = ["hyper", "hyper-multipart-rfc7578", "failure"]
+with-actix = ["actix-http", "actix-multipart-rfc7578", "awc", "derive_more"]
+with-builder = ["typed-builder"]
+# Old features, kept for compatibility
+actix = ["with-actix"]
+builder = ["with-builder"]
[dependencies]
actix-http = { version = "1.0", optional = true }