summaryrefslogtreecommitdiffstats
path: root/librepology/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@atos.net>2019-04-23 13:25:03 +0200
committerMatthias Beyer <matthias.beyer@atos.net>2019-04-23 15:52:00 +0200
commit44215217da63762b36827f5ef6604c5a2ad6b73d (patch)
treebfb48cc4bca7284e4ecffa92d0aa74e963ff38a0 /librepology/Cargo.toml
parent95e4800ddf616649c93811678cdd2016a3ebb786 (diff)
Add filters for Repo, Name, Status, Version, License and Maintainer
Diffstat (limited to 'librepology/Cargo.toml')
-rw-r--r--librepology/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/librepology/Cargo.toml b/librepology/Cargo.toml
index 7379b10..5f7bb52 100644
--- a/librepology/Cargo.toml
+++ b/librepology/Cargo.toml
@@ -15,3 +15,12 @@ failure = "0.1"
log = "0.4"
derive_more = "0.14"
curl = "0.4"
+
+filters = { version = "0.3", optional = true }
+derive-new = { version = "0.5", optional = true }
+
+[features]
+# By default, we include the filters functionality
+default = [ "packagefilters" ]
+
+packagefilters = ["filters", "derive-new"] \ No newline at end of file