summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorRobin Raymond <robin@robinraymond.de>2018-05-10 13:05:32 +0200
committerGitHub <noreply@github.com>2018-05-10 13:05:32 +0200
commit6d3ab77a5dee9ad6c289bad4421e3c39e8275bcb (patch)
treee6623aab17146020cbd3f32cb88253d307e32a86 /default.nix
parent02b0e867d2501f887fbd9797d37dd124e8df84fe (diff)
parent386faf960c657031a3d950c04d496b540139d399 (diff)
Merge pull request #114 from geistesk/message-id
Fog user's hostname in the Message-ID
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index cddb221..60e73da 100644
--- a/default.nix
+++ b/default.nix
@@ -444,6 +444,16 @@ in
'';
};
+ rewriteMessageId = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Rewrites the Message-ID's hostname-part of outgoing emails to the FQDN.
+ Please be aware that this may cause problems with some mail clients
+ relying on the original Message-ID.
+ '';
+ };
+
monitoring = {
enable = mkEnableOption "monitoring via monit";