summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorgeistesk <github.jyf300hj@0x21.biz>2018-04-08 20:58:30 +0200
committergeistesk <github.jyf300hj@0x21.biz>2018-04-09 22:14:17 +0200
commit386faf960c657031a3d950c04d496b540139d399 (patch)
tree8087525036e0ce62f3c3566ba83162ba4fce12b8 /default.nix
parent1dd394e63fa15d200faf83988f8fb5f9a54c04c5 (diff)
Fog user's hostname in the Message-ID
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 5ef87a3..989199a 100644
--- a/default.nix
+++ b/default.nix
@@ -433,6 +433,16 @@ in
'';
};
+ rewriteMessageId = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Rewrites the Message-ID's hostname-part of outgoing emails to the FQDN.
+ Please be aware that this may cause problems with some mail clients
+ relying on the original Message-ID.
+ '';
+ };
+
monitoring = {
enable = mkEnableOption "monitoring via monit";