summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorAntoine Eiche <lewo@abesis.fr>2020-09-28 20:50:45 +0200
committerAntoine Eiche <lewo@abesis.fr>2020-09-28 20:50:45 +0200
commit24600377afa853cb31654b1987530bbf2f0add79 (patch)
treeee15699ba36e7257043675a3aabe0c072d8ed510 /default.nix
parent5cd6f8e7b3f5d5bf56e407c5e79a682cb250d911 (diff)
Add `forwards` option
This option allow to forward mails to external addresses.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 22180ec..6372574 100644
--- a/default.nix
+++ b/default.nix
@@ -218,6 +218,24 @@ in
default = {};
};
+ forwards = mkOption {
+ type = with types; attrsOf (either (listOf str) str);
+ default = {};
+ example = {
+ "user@example.com" = "user@elsewhere.com";
+ };
+ description = ''
+ To forward mails to an external address. For instance,
+ the value {`"user@example.com" = "user@elsewhere.com";}`
+ means that mails to `user@example.com` are forwarded to
+ `user@elsewhere.com`. The difference with the
+ `extraVirtualAliases` option is that `user@elsewhere.com`
+ can't send mail as `user@example.com`. Also, this option
+ allows to forward mails to external addresses.
+ '';
+ default = {};
+ };
+
rejectSender = mkOption {
type = types.listOf types.str;
example = [ "@example.com" "spammer@example.net" ];