summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorJames ‘Twey’ Kay <twey@twey.co.uk>2020-09-05 21:23:15 +0100
committerlewo <lewo@abesis.fr>2020-09-18 21:38:15 +0000
commit5cd6f8e7b3f5d5bf56e407c5e79a682cb250d911 (patch)
tree6e80d657b152a147cf3b6be1935b2fc136ea70dd /default.nix
parent358cfcdfbe6ca137983c6629e174a98c306209cd (diff)
Add a separate sendingFqdn option
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix28
1 files changed, 27 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 6b96acd..22180ec 100644
--- a/default.nix
+++ b/default.nix
@@ -1,4 +1,3 @@
-
# nixos-mailserver: a simple mail server
# Copyright (C) 2016-2018 Robin Raymond
#
@@ -555,6 +554,33 @@ in
'';
};
+ sendingFqdn = mkOption {
+ type = types.str;
+ default = cfg.fqdn;
+ defaultText = "config.mailserver.fqdn";
+ example = "myserver.example.com";
+ description = ''
+ The fully qualified domain name of the mail server used to
+ identify with remote servers.
+
+ If this server's IP serves purposes other than a mail server,
+ it may be desirable for the server to have a name other than
+ that to which the user will connect. For example, the user
+ might connect to mx.example.com, but the server's IP has
+ reverse DNS that resolves to myserver.example.com; in this
+ scenario, some mail servers may reject or penalize the
+ message.
+
+ This setting allows the server to identify as
+ myserver.example.com when forwarding mail, independently of
+ `fqdn` (which, for SSL reasons, should generally be the name
+ to which the user connects).
+
+ Set this to the name to which the sending IP's reverse DNS
+ resolves.
+ '';
+ };
+
policydSPFExtraConfig = mkOption {
type = types.lines;
default = "";