summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2018-12-03 08:41:54 +0100
committerKevin McCarthy <kevin@8t8.us>2018-12-04 19:15:07 -0800
commitbf4a65ee6ea0bfedea8294334cc8fa5a2d51bd92 (patch)
tree353f4f2dd97b86eba3d4cbf44d59a269d8031115 /configure.ac
parent0725e71e00e0e03a83393e752224ee3d4edcd0b3 (diff)
Always use the gpgme_new wrapper in crypt-gpgme.
The wrapper is much more convenient and there is no need to sometimes use gpgme_new directly. The perceived advantage on not bailing out in an out-of-core condition is not realistic because other small amounts of memory are allocated all over mutt anyway and thus function will terminate the process as well. This patch also changes the minimum version of gpgme to 1.4.0. This is so that we can always pass NULL to functions like gpgme_release. Further 1.4.0 has new functions which we may soon like to use.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8ab8b0c3..892de59f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,11 +129,11 @@ AC_ARG_ENABLE(gpgme, AS_HELP_STRING([--enable-gpgme],[Enable GPGME support]),
if test x"$enable_gpgme" = xyes; then
AC_MSG_RESULT(yes)
- AM_PATH_GPGME(1.2.0, AC_DEFINE(CRYPT_BACKEND_GPGME, 1,
+ AM_PATH_GPGME(1.4.0, AC_DEFINE(CRYPT_BACKEND_GPGME, 1,
[Defined, if GPGME support is enabled]),
[gpgme_found=no])
if test x"$gpgme_found" = xno; then
- AC_MSG_ERROR([*** GPGME not found or version is older than 1.2 ***])
+ AC_MSG_ERROR([*** GPGME not found or version is older than 1.4 ***])
else
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS crypt-gpgme.o crypt-mod-pgp-gpgme.o crypt-mod-smime-gpgme.o"
fi