summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2018-12-03 08:41:53 +0100
committerKevin McCarthy <kevin@8t8.us>2018-12-04 18:58:20 -0800
commit0725e71e00e0e03a83393e752224ee3d4edcd0b3 (patch)
treeb847042d94c287c13225dc949b192113c593b5d9 /configure.ac
parent125c955d8da8bafd7c02bf784b624bd9b0e2b235 (diff)
Require GPGME version 1.2.0 and drop useless HAVE macros.
GPGME 1.2.0 was released nearly 10 years ago and thus we can really demand this version. For various reasons it would be advisable to require a decent version but that is a different thing and needs to be done in a separate patch. HAVE_GPGME_OP_EXPORT_KEYS and HAVE_GPGME_PKA_TRUST are not anymore needed because they are supported by that GPGME version. Signed-off-by: Werner Koch <wk@gnupg.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d8aebe33..8ab8b0c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,22 +129,12 @@ AC_ARG_ENABLE(gpgme, AS_HELP_STRING([--enable-gpgme],[Enable GPGME support]),
if test x"$enable_gpgme" = xyes; then
AC_MSG_RESULT(yes)
- AM_PATH_GPGME(1.0.0, AC_DEFINE(CRYPT_BACKEND_GPGME, 1,
+ AM_PATH_GPGME(1.2.0, AC_DEFINE(CRYPT_BACKEND_GPGME, 1,
[Defined, if GPGME support is enabled]),
[gpgme_found=no])
if test x"$gpgme_found" = xno; then
- AC_MSG_ERROR([*** GPGME not found ***])
+ AC_MSG_ERROR([*** GPGME not found or version is older than 1.2 ***])
else
- AM_PATH_GPGME(1.1.1, AC_DEFINE(HAVE_GPGME_PKA_TRUST, 1,
- [Define if GPGME supports PKA]))
- #needed to get GPGME_LIBS and al correctly
- AM_PATH_GPGME(1.0.0, AC_DEFINE(CRYPT_BACKEND_GPGME, 1,
- [Define if you use GPGME to support OpenPGP]))
- dnl AC_CHECK_FUNCS([gpgme_op_export_keys])
- saved_LIBS="$LIBS"
- LIBS="$LIBS $GPGME_LIBS"
- AC_CHECK_FUNCS([gpgme_op_export_keys])
- LIBS="$saved_LIBS"
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS crypt-gpgme.o crypt-mod-pgp-gpgme.o crypt-mod-smime-gpgme.o"
fi
else