summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-07-04 22:30:58 +0200
committerMatthias Beyer <mail@beyermatthias.de>2020-07-04 22:31:33 +0200
commitf094d3a0c50bfe7b48b0c5f8ebd46a52fd2cdba8 (patch)
tree768e57aade36c4a9e9155e43159cb5b6ba996de5 /shell.nix
Initial import
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..df41ddf
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,28 @@
+{ ... }:
+
+let
+ moz_overlay = import (
+ builtins.fetchTarball https://github.com/mozilla/nixpkgs-mozilla/archive/master.tar.gz
+ );
+
+ pkgs = import <nixpkgs> { overlays = [ moz_overlay ]; };
+in
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ rustChannels.stable.rust-std
+ rustChannels.stable.rust
+ rustChannels.stable.rustc
+ rustChannels.stable.cargo
+
+ cmake
+ curl
+ gcc
+ libpsl
+ openssl
+ pkgconfig
+ ncurses
+ ];
+ LIBCLANG_PATH = "${pkgs.llvmPackages.libclang}/lib";
+}
+
+