summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-01-23 18:04:59 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-01-30 13:01:33 +0100
commit99446027a16ae77ac22745767637ac28ba659bde (patch)
tree953304d91a5e709435f89820003094bd6588c6ff /Cargo.toml
parent9008d4bd4643a9e32db9172b2c3b93b0a19a34ce (diff)
Complete restructuring
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c56a614..aeaf644 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,14 +8,15 @@ version = "0.1.0"
anyhow = "1"
chrono = "0.4"
config = "0.10"
-cursive = "0.15"
+cursive = "0.16"
cursive-async-view = "0.4"
cursive-flexi-logger-view = { git = "https://github.com/deinstapel/cursive-flexi-logger-view/" }
-cursive-multiplex = "0.4"
-cursive-tabs = "0.5"
+cursive-multiplex = { git = "https://github.com/matthiasbeyer/cursive-multiplex", branch = "getters" }
+cursive-tabs = { git = "https://github.com/matthiasbeyer/cursive-tabs", branch = "getters" }
cursive_table_view.git = "https://git.sr.ht/~matthiasbeyer/cursive_table_view"
env_logger = "0.7"
-flexi_logger = "0.15"
+flexi_logger = "0.17"
+failure = "0.1"
getset = "0.1"
handlebars = "3"
indoc = "1"
@@ -26,6 +27,7 @@ notmuch = "0.6"
result-inspect = "0.1"
serde = { version = "1.0", features = ["derive"] }
walkdir = "2"
+parse-display = "0.4"
[dependencies.cursive_tree_view]
git = "https://github.com/matthiasbeyer/cursive_tree_view"