summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2021-01-14 19:57:32 +0100
committerMatthias Beyer <mail@beyermatthias.de>2021-01-14 20:55:30 +0100
commit328601602712958ad5e201d239f62440a1b02401 (patch)
tree051e24bc8a4cbf0261f9368b41545d308ed7d682 /Cargo.toml
parent48e862f21dfee6b2bf31cf16625a64f73527feda (diff)
Wrap view in a cursive_multiplex
Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4c95a4a..b089734 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,9 +8,12 @@ version = "0.1.0"
anyhow = "1"
chrono = "0.4"
config = "0.10"
+cursive = "0.15"
cursive-async-view = "0.4"
cursive-flexi-logger-view = { git = "https://github.com/deinstapel/cursive-flexi-logger-view/" }
+cursive-multiplex = "0.4"
cursive-tabs = "0.5"
+cursive_core = "0.1"
cursive_table_view.git = "https://git.sr.ht/~matthiasbeyer/cursive_table_view"
env_logger = "0.7"
flexi_logger = "*"
@@ -18,12 +21,9 @@ handlebars = "3"
log = "0.4"
mailparse.git = "https://git.sr.ht/~matthiasbeyer/mailparse"
notmuch = "0.6"
+result-inspect = "0.1"
serde = { version = "1.0", features = ["derive"] }
walkdir = "2"
-result-inspect = "0.1"
-
-cursive = "0.15"
-cursive_core = "0.1"
[dependencies.cursive_tree_view]
git = "https://github.com/matthiasbeyer/cursive_tree_view"