summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-07-15 14:38:43 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-07-15 15:24:01 +0300
commit77dc1d74bf6fa65048d425997d295909ea269d10 (patch)
tree8606e8d59a60d0968a1730ef02ed500da1bbdb6b /Cargo.toml
parentddafde7b3794b255e846fa20ba6f00ca2ef4eeed (diff)
Add smtp client support for sending mail in UI
`mailer_command` was removed, and a new setting `send_mail` was added. Its possible values are a string, consisting of a shell command to execute, or settings to configure an smtp server connection. The configuration I used for testing this is: [composing] send_mail = { hostname = "smtp.mail.tld", port = 587, auth = { type = "auto", username = "yoshi", password = { type = "command_eval", value = "gpg2 --no-tty -q -d ~/.passwords/msmtp/yoshi.gpg" } }, security = { type = "STARTTLS" } } For local smtp server: [composing] send_mail = { hostname = "localhost", port = 25, auth = { type = "none" }, security = { type = "none" } }
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43a62165..0da12aab 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -69,10 +69,11 @@ debug = false
members = ["melib", "testing", ]
[features]
-default = ["sqlite3", "notmuch", "regexp"]
+default = ["sqlite3", "notmuch", "regexp", "smtp"]
notmuch = ["melib/notmuch_backend", ]
jmap = ["melib/jmap_backend",]
sqlite3 = ["melib/sqlite3"]
+smtp = ["melib/smtp"]
regexp = ["pcre2"]
cli-docs = []
svgscreenshot = ["svg_crate"]