summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-02-04 17:26:25 +0200
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-02-04 17:29:55 +0200
commit05b91f1c02a273c653a73569493f8e7154a62a11 (patch)
treedcfbcc0ffd82114c05c8ac7e3d5d74815f5d0df2 /Cargo.toml
parent8b6ea8de9a89b3ad42276eb7835992f7b875128b (diff)
Remove text_processing
Unwrap text_processing into melib In preparation for uploading meli as a separate crate on crates.io.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a92df14b..53dc3e3e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,7 +14,7 @@ crossbeam = "0.7.2"
signal-hook = "0.1.12"
signal-hook-registry = "1.2.0"
nix = "0.16.1"
-melib = { path = "melib", version = "0.4.1" }
+melib = { path = "melib", version = "0.5.0" }
serde = "1.0.71"
serde_derive = "1.0.71"
@@ -30,7 +30,6 @@ termion = "1.5.1"
bincode = "1.2.0"
uuid = { version = "0.7.4", features = ["serde", "v4"] }
unicode-segmentation = "1.2.1" # >:c
-text_processing = { path = "text_processing", version = "0.4.1" }
libc = {version = "0.2.59", features = ["extra_traits",]}
rusqlite = {version = "0.20.0", optional =true }
rmp = "^0.8"
@@ -44,7 +43,7 @@ lto = true
debug = false
[workspace]
-members = ["melib", "testing", "text_processing"]
+members = ["melib", "testing", ]
[features]
default = ["sqlite3"]