summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-02-04 15:52:12 +0200
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-02-04 17:29:55 +0200
commit8b6ea8de9a89b3ad42276eb7835992f7b875128b (patch)
tree864a7136b4c23d76761ee3e7d034307f8c302838 /Cargo.toml
parent6fcc792b83f715644c041f728049de65f7da2e38 (diff)
Remove ui crate
Merge ui crate with root crate. In preparation for uploading `meli` as a separate crate on crates.io. Workspace crates will need to be published as well and having a separate `ui` crate and binary perhaps doesn't make sense anymore.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml35
1 files changed, 29 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8247ec91..a92df14b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,21 +14,44 @@ crossbeam = "0.7.2"
signal-hook = "0.1.12"
signal-hook-registry = "1.2.0"
nix = "0.16.1"
-melib = { path = "melib", version = "*" }
-ui = { path = "ui", version = "*" }
+melib = { path = "melib", version = "0.4.1" }
+
+serde = "1.0.71"
+serde_derive = "1.0.71"
+serde_json = "1.0"
+toml = "0.5.3"
+fnv = "1.0.3" # >:c
+linkify = "0.3.1" # >:c
+xdg-utils = "0.3.0"
+nom = "3.2.0"
+notify = "4.0.1" # >:c
+notify-rust = "^3" # >:c
+termion = "1.5.1"
+bincode = "1.2.0"
+uuid = { version = "0.7.4", features = ["serde", "v4"] }
+unicode-segmentation = "1.2.1" # >:c
+text_processing = { path = "text_processing", version = "0.4.1" }
+libc = {version = "0.2.59", features = ["extra_traits",]}
+rusqlite = {version = "0.20.0", optional =true }
+rmp = "^0.8"
+rmpv = { version = "^0.4.2", features=["with-serde",] }
+rmp-serde = "^0.14.0"
+smallvec = { version = "1.1.0", features = ["serde", ] }
+
[profile.release]
lto = true
debug = false
[workspace]
-members = ["melib", "ui", "debug_printer", "testing", "text_processing"]
+members = ["melib", "testing", "text_processing"]
[features]
-default = []
-notmuch = ["melib/notmuch_backend", "ui/notmuch"]
+default = ["sqlite3"]
+notmuch = ["melib/notmuch_backend", ]
jmap = ["melib/jmap_backend",]
+sqlite3 = ["rusqlite"]
# Print tracing logs as meli runs in stderr
# enable for debug tracing logs: build with --features=debug-tracing
-debug-tracing = ["melib/debug-tracing", "ui/debug-tracing"]
+debug-tracing = ["melib/debug-tracing", ]