summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2020-06-20 23:28:50 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2020-06-20 23:58:53 +0300
commit0169025d503519f5223c9d29ae0c955177a91a6b (patch)
treeeddf1b17784237af9c4ef6339ee4be4172d833ea /Cargo.toml
parent1db2c16f95cf27d3599f7f021f68b3b2d549fda7 (diff)
build.rs: add proc-macro to generate Override structs for configuration
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f26581ef..36822e4c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,6 +52,10 @@ pcre2 = { version = "0.2.3", optional = true }
structopt = { version = "0.3.14", default-features = false }
svg_crate = { version = "0.8.0", optional = true, package = "svg" }
+[build-dependencies]
+syn = { version = "1.0.31", features = [] }
+quote = "^1.0"
+proc-macro2 = "1.0.18"
[profile.release]
lto = true