summaryrefslogtreecommitdiffstats
path: root/smtp/Cargo.toml
diff options
context:
space:
mode:
authorPhilipp Korber <p.korber@1aim.com>2018-11-16 16:15:42 +0100
committerPhilipp Korber <p.korber@1aim.com>2018-11-16 16:15:42 +0100
commitcaf049791b8e7107734cd1f8917d51c91a2b80ad (patch)
tree338b7edede2a3df91e6712f0567bce61a705fc66 /smtp/Cargo.toml
parentbad94a94285a6d13cb02c26702c525a9e1b3e32f (diff)
refactor: prepared to be merged into different repository
Diffstat (limited to 'smtp/Cargo.toml')
-rw-r--r--smtp/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/smtp/Cargo.toml b/smtp/Cargo.toml
new file mode 100644
index 0000000..536a92e
--- /dev/null
+++ b/smtp/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+authors = ["Philipp Korber <p.korber@1aim.com>"]
+name = "mail-smtp"
+version = "0.2.0-wip"
+categories = []
+description = "[internal/mail-api] combines mail-core with new-tokio-smtp"
+documentation = "https://docs.rs/mail-smtp"
+keywords = ["mail-api"]
+license = "MIT OR Apache-2.0"
+readme = "./README.md"
+repository = "https://github.com/1aim/mail-smtp"
+
+[dependencies]
+futures = "0.1"
+failure = "0.1.1"
+mail-core = { path="../core" }
+mail-headers = { path="../headers"}
+mail-internals = { path="../internals" }
+new-tokio-smtp = "0.8.1"
+
+[features]
+test-with-traceing = ["mail-internals/traceing"]
+extended-api = [] \ No newline at end of file