summaryrefslogtreecommitdiffstats
path: root/mail/Cargo.toml
diff options
context:
space:
mode:
authorPhilipp Korber <p.korber@1aim.com>2018-11-16 15:46:43 +0100
committerPhilipp Korber <p.korber@1aim.com>2018-11-16 15:46:43 +0100
commit652d6f0ffeee7302a2cb51059bef75d8b0bb50be (patch)
treec3851592642938172f280f7428d43e08b0fe2cbe /mail/Cargo.toml
parent0947fe8996149fe20a6d47a793f9555790eb2eae (diff)
refactor: merged sources of mail-headers,mail-internals,mail-core, mail
Originally it was palaned to do a merge with `--allow-unrelated-history` but this can not be doesn as `mail-core` has a "invalid" history which has a merge conflict **with itself**. So even rewinding the history on a empty repo is not possible. Instead the code was directly coppied over losing history. But the history is still available in the different `history-backup-*` branches. It is just that the past history is decoupled from the current history.
Diffstat (limited to 'mail/Cargo.toml')
-rw-r--r--mail/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/mail/Cargo.toml b/mail/Cargo.toml
new file mode 100644
index 0000000..6d198d6
--- /dev/null
+++ b/mail/Cargo.toml
@@ -0,0 +1,42 @@
+[package]
+name = "mail"
+version = "0.1.0"
+authors = ["Philipp Korber <philippkorber@gmail.com>"]
+categories = []
+#TODO go through the keywords
+keywords = ["mail", "rfc5322", "email", "mime", "smtp", "template"]
+description = "mail, facade for a number of mail related crates for creating and sending mails"
+license = "MIT OR Apache-2.0"
+readme = "./README.md"
+repository = "https://github.com/1aim/mail"
+
+[features]
+smtp = ["mail-smtp"]
+#askama-engine = ["mail-template/askama-engine"]
+#tera-engine = ["render-template-engine", "mail-render-template-engine/tera-engine"]
+#handlebars-engine = ["render-template-engine", "mail-render-template-engine/handlebars-engine"]
+#render-template-engine = ["mail-render-template-engine"]
+
+traceing = ["mail-internals/traceing", "mail-headers/traceing"]
+
+
+
+[dependencies]
+mail-internals = { git="https://github.com/1aim/mail-internals" }
+mail-headers = { git="https://github.com/1aim/mail-headers" }
+mail-core = { git="https://github.com/1aim/mail-types" }
+#mail-template = { git="https://github.com/1aim/mail-template" }
+mail-derive = { git="https://github.com/1aim/mail-derive" }
+mail-smtp = { git="https://github.com/1aim/mail-smtp", optional=true }
+#mail-render-template-engine = {git="https://github.com/1aim/mail-render-template-engine", optional=true }
+
+[dev-dependencies]
+rpassword = "2.0.0"
+tokio = "0.1.1"
+serde = "1.0.10"
+serde_derive = "1.0.10"
+soft-ascii-string = "1.0"
+futures = "0.1.0"
+failure = "0.1.1"
+
+