summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFabio Valentini <decathorpe@gmail.com>2024-02-05 13:53:46 +0100
committerWei Zhang <kweizh@gmail.com>2024-02-16 11:30:41 +0800
commit0d2e36ac99eaa99d3d23ef950fb4a226139d6a29 (patch)
tree02c5df113ff24022c8bb3e73b16b95d9e86f32e5 /Cargo.toml
parent73eeb7f71735bbef6fd3ed2d67a4f52f1c0423bf (diff)
update various dependencies
- update dirs from v4 to v5 (no code changes) - update term_grid from v0.1 to v0.2 (small code changes) - update terminal_size from v0.1 to v0.3 (no code changes) - update lscolors from v0.15 to v0.16 (no code changes) - update serde_yaml from v0.8 to v0.9 (no code changes) The term_grid update required small changes to the use of `term_grid::Cell` because with v0.2, it is possible to specify the alignment within the cell. Adding `Alignment::Left` should preserve the current behaviour. This commit also includes the changes generated by "cargo update", which seems not to have been run in a long time, causing very old versions to be pulled in.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3c2ed42..de93e26 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,24 +23,24 @@ version_check = "0.9.*"
[dependencies]
crossterm = { version = "0.27.0", features = ["serde"] }
-dirs = "4"
+dirs = "5"
libc = "0.2.*"
human-sort = "0.2.2"
-term_grid = "0.1.*"
-terminal_size = "0.1.*"
+term_grid = "0.2"
+terminal_size = "0.3"
thiserror = "1.0"
sys-locale = "0.3"
once_cell = "1.17.1"
chrono = { version = "0.4.*", features = ["unstable-locales"] }
chrono-humanize = "0.2"
unicode-width = "0.1.*"
-lscolors = "0.15.0"
+lscolors = "0.16.0"
wild = "2.0"
globset = "0.4.*"
xdg = "2.1"
yaml-rust = "0.4.*"
serde = { version = "1.0", features = ["derive"] }
-serde_yaml = "0.8"
+serde_yaml = "0.9"
url = "2.1"
vsort = "0.2"