summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01a7ed12..327dc6d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,11 +54,16 @@ include_HEADERS = src/jv.h src/jq.h
### Running tests under Valgrind
+if ENABLE_ASAN
+AM_CFLAGS += -fsanitize=address
+NO_VALGRIND = 1
+else
if ENABLE_VALGRIND
NO_VALGRIND =
else
NO_VALGRIND = 1
endif
+endif
### Code coverage with gcov